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1 Licensing 
A license enables a server to be deployed and managed by the Altiris Deployment Server. One license is required for 
each server being managed. After a license is applied to a specific server, the license cannot be removed or 
transferred to another server. 

A license file contains licenses for a predetermined number of servers. License files are not Rapid Deployment Pack 
version specific. 

 NOTE:  The term “server” refers to a physical server or a virtual machine. One license is required for each 
physical server or virtual machine. 
 

Licensing options 
The Rapid Deployment Pack offers five license purchasing options: 

• One-node license—This license enables you to deploy and manage one server through the Deployment Server. 
• Ten-node license—This license enables you to deploy and manage 10 servers through the Deployment Server. 
• Flexible Quantity license—These kits enable you to obtain an exact quantity of licenses in the purchase of a 

single software option kit. 
• Activation Key Agreement—This option enables you to order keys in the quantity desired for a specific time and 

purchase a license for each server deployed over time. 
• HP BladeSystem enclosure group—A bundle of 8 or 20 licenses is available with an HP BladeSystem enclosure. 
For more information about Flexible Quantity license and Activation Key Agreement options, see ProLiant Essentials 
Licensing at http://www.hp.com/servers/rdp. 

Obtaining licenses 
The following sections explain how to obtain evaluation or purchased licenses for your servers. 

Evaluation licenses 
Two types of evaluation licenses are available for use: 

• A 10-node, 7-day evaluation license is built into the Deployment Server. No license file is required. The 
evaluation license can be applied during the Deployment Server installation. 

• To obtain and use a 10-node, 30-day evaluation license: 
a. Access http://www.hp.com/servers/rdp/eval. 
b. Follow the online instructions to complete the registration process. An evaluation license file is then e-mailed 

to you. 

Purchased licenses 
Use your unique product registration number to obtain a license file. A 16-character alpha or 20-character 
alphanumeric registration number is located on a label on the outside back panel of a purchased software packaging 
box. The registration number is in the form: 

xxxx-xxxx-xxxx-xxxx or xxxxx-xxxxx-xxxxx-xxxxx 

 IMPORTANT:  Keep your product registration number for future reference. 
 

1. Access http://www.hp.com/servers/rdp/register. 
2. Follow the online instructions to complete the registration process. A license file will be e-mailed to you. 
Additional purchased licenses can be transferred or combined with already registered licenses. See the instructions at 
http://www.hp.com/servers/rdp/register. 

Applying a license file 
The following sections explain how to apply evaluation or purchased licenses to your servers and how to add or 
replace existing licenses. 

http://www.hp.com/servers/rdp
http://www.hp.com/servers/rdp/eval
http://www.hp.com/servers/rdp/register
http://www.hp.com/servers/rdp/register
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Applying license files during a first-time installation 
A 10-node, 7-day evaluation license is built into the Deployment Server. To apply this license, select Free 7 day 
license during a first-time installation on the Deployment Share Information screen. 

To apply a purchased or evaluation license file, enter the path to the license file in the License File field during the 
installation on the Deployment Share Information screen. 

To view the number of licensed nodes from the console, select Help>About. 

Applying license files during an upgrade installation 
To continue using existing licenses after performing an upgrade, select Upgrade using existing license during the 
installation on the Deployment Share Information screen. 

To view the number of licensed nodes from the console, select Help>About. 

Adding licenses to an existing installation 
To apply additional purchased licenses to an existing installation, add the new license file to your Deployment Server: 

1. Shut down all connections to the Deployment Server Console and Deployment Server Web Console. 
2. Run the Altiris Product Licensing Utility by clicking Start>Programs>Altiris>Deployment Solution> 

Product Licensing Utility. 
3. Enter the path to the new license file in the Activation Key File Information field, and then click Next. 
4. Follow the online instructions to apply your additional licenses. 
To view the number of additional licensed nodes from the console, select Help>About. 

Replacing licenses in an existing installation 
If you have previously purchased, returned, or transferred licenses and have obtained a new license file to replace 
your existing license file: 

1. Shut down all connections to the Deployment Server Console and Deployment Server Web Console. 
2. Run the Altiris Product Licensing Utility by selecting Start>Programs>Altiris>Deployment Solution> 

Product Licensing Utility. 
3. Enter the path to the new license file in the Activation Key File Information field, and then click Next. 
4. Follow the online instructions to apply your licenses, and select Replace all existing license Activation Keys with 

this new Activation Key checkbox. 
To view the number of licensed nodes from the console, select Help>About. 
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2 Prerequisites 
The Rapid Deployment Pack installation consists of the following required components installed on a Microsoft® 
Windows®-based server. 

• Microsoft .NET Framework 1.1 and 2.0 
• Microsoft SQL Server 2005 Express 

 IMPORTANT:  The above database component is installed only if you do not already have a local or 
remote Microsoft SQL database. 

 

• Altiris Deployment Server, including any available service packs 
• Altiris Deployment Server Hotfix (if available) 
• ProLiant Integration Module 
• Integrity Integration Module 
The Altiris Deployment Server consists of subcomponents that can be installed on the same physical server or 
distributed across multiple servers. These subcomponents include the following: 

• Deployment Server Services 
• Deployment Server Console 
• Deployment Server Web Console (optional) 
• Preboot eXecution Environment (PXE) service 
• Client Access Point (file share) 
For information about the specific component versions provided with the Rapid Deployment Pack, see the HP ProLiant 
Essentials Rapid Deployment Pack Release Notes, which are accessible from the Rapid Deployment Pack 
autorun utility. 

Installation requirements 
This section describes the requirements to successfully install each Rapid Deployment Pack component. 

 IMPORTANT:  The Rapid Deployment Pack cannot be installed through a Terminal Services, remote shell, or 
network share connection. 
 

Network infrastructure requirements 
The Rapid Deployment Pack is designed to perform optimally with Dynamic Host Configuration Protocol (DHCP) and 
PXE in the network environment. If PXE is used to perform remote deployment of servers, DHCP must be installed and 
accessible on the network before the Altiris Deployment Server installation to ensure correct installation of PXE 
services. 

System requirements 
The following system requirements for the Deployment Server and target systems must be met before installing the 
Rapid Deployment Pack. 
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Deployment Server 
The Deployment Server hardware and network configuration must meet the following requirements: 

• An Intel® Pentium® III or higher processor or AMD processor 
• At least 256 MB RAM 
• A network connection configured with a static IP address 

 IMPORTANT:  It is difficult to change the IP address configuration for the Deployment Server after 
installation. Set the appropriate IP address before installing the Rapid Deployment Pack. 

 
• The correct date and time 
• A DVD drive or method to mount an ISO image 
The Deployment Server configuration must meet the following requirements: 

• A supported Windows operating system installed: 
• Microsoft Windows 2000 Server 
• Microsoft Windows 2000 Advanced Server 
• Microsoft Windows Server™ 2003 Service Pack 1, Standard Edition 
• Microsoft Windows Server 2003 Service Pack 1, Enterprise Edition 

 NOTE:  Altiris does not support a deployment server running Microsoft Windows Server 2003 x64 or 
IA64 Editions. 

 
• Available disk space: 

• 1.5 GB for the Rapid Deployment Pack base installation 
• At least 500 MB for each Windows operating system to deploy 
• At least 600 MB for each VMware operating system to deploy 
• At least 4 GB for each Linux distribution to deploy 
• Additional space to store any captured disk images or application installation files 

• Database management software  
• Microsoft SQL Server 2000 3a or later 
• Microsoft SQL Server 2005 

• For Linux and VMware ESX Server deployments, an FTP server installed, such as the Microsoft Internet 
Information Services (IIS) FTP service. For information, see “Appendix C Installing an FTP server.” 

• ProLiant Support Pack for Windows installed to provide the latest supported network drivers for the 
Deployment Server 

• IIS with ASP.NET running if you want to install and use the Deployment Server Web Console 
Be sure to have the following items available: 

• A license file for purchased licenses or 30-day evaluation licenses (For information about licensing, see the 
“Licensing” section in this guide.) 

• Operating system files for Windows, VMware ESX Server, Linux, or all three with versions as described in the 
HP ProLiant Essentials Rapid Deployment Pack—Windows Edition Support Matrix 

• Windows product keys 
For additional information about requirements for the Deployment Server, see the Altiris Deployment Solution 6.8 
Deployment and Migration Guide at http://www.hp.com/servers/rdp. 

Target systems 
The Rapid Deployment Pack offers support for HP BladeSystems, including ProLiant BL servers, Integrity BL servers, 
and Blade PCs, as well as select ProLiant ML/DL servers, Integrity rx servers and select virtual machines. For a list of 
supported systems, see the HP ProLiant Essentials Rapid Deployment Pack—Windows Edition Support Matrix for your 
Rapid Deployment Pack version. 

For details about target system requirements, such as minimum ROM and firmware versions, see the Rapid 
Deployment Pack Knowledge Base at http://www.hp.com/servers/rdp/kb. Search for related articles based on the 
platform model, name, or operating system. See also the Knowledge Base article, “Minimum Firmware Requirements 
for Target Servers,” Article #200. 

http://www.hp.com/servers/rdp
http://www.hp.com/servers/rdp/kb
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3 Installing 
Complete the following procedures to install the Rapid Deployment Pack. To upgrade the Rapid Deployment Pack 
software currently installed on the Deployment Server, see the “Upgrading” section in this guide. 

 IMPORTANT:  The Rapid Deployment Pack cannot be installed through a Terminal Services, remote shell, or 
network share connection. 
 

1. Access the Rapid Deployment Pack autorun by performing one of the following tasks, and executing 
autorun.exe: 
• Insert the physical DVD into the DVD drive. 
• Extract the ISO image to the intended Deployment Server. 
• Mount the ISO image. 

2. If you agree to the terms of the ProLiant Essentials End User License Agreement (EULA), click Agree to continue. 
3. Read the overview information, and click Next. 
4. Review the preinstallation step, and click Next. 
5. Verify that the appropriate components are selected for installation. If Microsoft .NET Framework and 

Microsoft SQL Server are not installed on the server, these components are automatically selected. If you plan to 
use an existing database, clear the Microsoft SQL Server 2005 Express option. 

 
6. Click Install. 
7. Wait while Microsoft .NET Framework and Microsoft SQL Server are installed. 
8. If the Altiris Deployment Server was selected for installation, read the Altiris EULA, and click Yes to agree to the 

terms of the license agreement. If the Altiris Deployment Server was not selected for installation, proceed to step 
26. 
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9. If the server has multiple network adapters, select the appropriate interface for the Deployment Server, and 
click Select IP. 

 
10. Select the appropriate licensing option. For more information about licensing, see the “Licensing” section in this 

guide. 
• For a first-time installation, select Free 7 day license, or select License file, and enter the license file path and 

name. 

 
 

 CAUTION:  To avoid losing existing licenses, you must select Upgrade using existing license during an 
upgrade installation instead of selecting License file and reapplying your original license file. 
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• For an upgrade installation, verify that Upgrade using existing license is selected. 

 
11. Click Next. 
12. Enter the service credentials for the Deployment Server, and click Next. 
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13. Select the name of the server instance where you want to install the database, and click Next. 

 
14. If the database is located on a remote server, you might be prompted for authentication. Enter a user name and 

password with administrative rights. 
15. Enter the appropriate database authentication method, and click Next. 
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16. If upgrading, click Yes when prompted to retain the data in the existing database. 
 

 CAUTION:  If you do not retain existing data, all deployment history, customized jobs, and servers listed 
in the Deployment Server Console are lost. 

 

17. Click Next on the Pre-boot Operating Systems screen. 
 

 IMPORTANT:  Linux and Windows PE are the only automation environments supported with the Rapid 
Deployment Pack 3.00 or later. The MS-DOS preboot environment is no longer used. For the Rapid 
Deployment Pack 3.50 and later, Windows PE x86, Windows PE x64, Linux PE x86, and Linux PE ia64 
are the only preboot architectures supported.  
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18. Specify the location where PXE Server is to be installed, and click Next. 

 
19. If DHCP is installed on a separate system, click OK when prompted that DHCP services are required. 
20. Specify how clients connect to the Deployment Server, and click Next. 
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21. Specify the location where the Deployment Server Console is to be installed, and click Next. 

 
22. Specify if and where the Deployment Server Web Console is to be installed, and click Next. 
 

 IMPORTANT:  Microsoft IIS with ASP.NET must be running on the system where the Deployment Server 
Web Console is installed. 

 

 



Installing 15  
 
 

23. Click Install on the Installation Information screen to start the Deployment Server software installation.  

 
24. If upgrading, click Yes when prompted to replace the eXpress share. 
25. Click Finish on the Installation Information Summary screen. 
26. If ProLiant Integration Module software was selected for installation, click Verify on the Prerequisites screen to 

start the verification process. If ProLiant Integration Module software was not selected, proceed to step 37 for 
Integrity Integration Module software. 

27. Click Next when the verification process is complete. 
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28. Select the operating systems that are to be deployed to target systems, and click Next. 
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29. Specify the appropriate configuration options. If you are not using IIS FTP service for Linux or VMware ESX 
Server installations, clear the Create IIS FTP virtual directory “DSLIB” option. 
For additional information or to change these configuration options later, see “Appendix B Manually modifying 
configuration settings.” 

30. Click Next. 

 
31. Click Install on the Installation and Configuration screen. 
32. If upgrading, click OK if you are prompted to overwrite the existing jobs and save configuration backup files. 
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33. Based on your previous selection of operating systems to deploy to target systems, specify the root directory 
location for the indicated operating systems. The operating system files can be copied from CDs or DVDs, a 
network location, or a mounted ISO image. Click Copy to copy necessary files for scripted installations. 
If the operating system files have already been copied, you are not prompted for those files again. 

 

 IMPORTANT:  If you bypass copying any operating system files at this time by clicking Skip, see “Appendix A 
Manually installing operating system CDs or DVDs” to manually install these files later. Manually copying the 
Windows, Linux, or VMware operating system files produces the same results as copying the files during the 
Rapid Deployment Pack installation.  
 

 
34. If the same media source was used to install the operating system files, you are prompted to reinsert the Rapid 

Deployment Pack media when the copy process is complete. Click OK when you have reinserted the media. 
35. If you bypassed copying any operating system files in step 33, click OK when the warning message appears 

stating which distributions were not copied. 
36. Click Finish on the Installation and Configuration screen. 
37. If the Integrity Integration Module software was selected for installation, click Verify on the Prerequisites screen 

to start the verification process. If Integrity Integration Module software was not selected, proceed to step 48. 
38. Click Next when the verification process is complete. 
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39. Select the operating systems that are to be deployed to target systems, and click Next. 

 
40. Specify the appropriate configuration options. If you are not using IIS FTP service for Linux installations, clear 

the Create IIS FTP virtual directory “DSLIB” option. For additional information to change these configuration 
options later, see “Appendix B Manually modifying configuration settings” in this guide. 

 
41. Click Next. 
42. Click Install on the Installation and Configuration screen. 
43. If upgrading, click OK if you are prompted to overwrite the existing jobs and save configuration backup files. 
44. Based on your previous selection of operating systems to deploy to target systems, specify the root directory 

location for the indicated operating systems. The operating system files can be copied from CDs or DVDs, a 
network location, or a mounted ISO image. Click Copy to copy necessary files for scripted installations. If the 
operating system files have already been copied, you are not prompted for those files again. 
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 IMPORTANT:  If you bypass copying any operating system files at this time by clicking Skip, see 
“Appendix A Manually installing operating system CDs or DVDs” to manually install these files later. 
Manually copying the Windows and Red Hat Linux operating system files produces the same results as 
copying the files during the Rapid Deployment Pack installation. 

 

45. If the same media source was used to install the operating system files, you are prompted to reinsert the Rapid 
Deployment Pack media when the copy process is complete. Click OK when you have reinserted the media. 

46. If you bypassed copying any operating system files in step 44, click OK when the warning message appears 
stating which distributions were not copied. 

47. Click Finish on the Installation and Configuration screen. 
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48. Click Next on the autorun utility. 

 
49. Review the post-installation step, and click Finish to complete the Rapid Deployment Pack installation. 
50. Select Yes when prompted to reboot the server. 
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The installation is complete. Before performing a server deployment, see the following resources: 

• The “Post-installation steps” section in this guide 
• The appropriate predeployment configuration steps in the HP ProLiant Essentials Rapid Deployment Pack—

Windows Edition User Guide 
 

 IMPORTANT:  During the Rapid Deployment Pack installation, the default Linux Managed and WinPE 
Managed PXE images are automatically regenerated if PXE is used. However, if you performed an 
upgrade installation, rebuild any custom PXE or boot images to ensure that these images contain the 
latest files and drivers.  
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4 Upgrading 
Complete the following procedures to upgrade the Rapid Deployment Pack software currently installed on the 
Deployment Server. 

Preinstallation steps 
 IMPORTANT:  If you have modified any of the provided batch files, configuration files, or scripts, verify that you have 

renamed and made backup copies of this data before upgrading. The upgrade program might overwrite these files with 
new files. 

 

 IMPORTANT:  The Rapid Deployment Pack upgrade must be completed using the Rapid Deployment Pack—Windows 
Edition autorun utility. Verify that the Upgrade using existing license option is selected during the Altiris Deployment Server 
upgrade. 

 

Before upgrading: 

• If you obtained your existing licenses before 20 November 2003, you should have received a new license file 
validating your licenses for an Altiris 6.0 or later software upgrade and providing 10-year Annual Upgrade 
Protection. Before upgrading to the Rapid Deployment Pack 1.50 or later, apply this new license file with the 
Altiris Product Licensing Utility, verifying that Replace all existing license Activation Keys with this new Activation 
Key checkbox is not selected. This new license file is to be used with your purchased licenses, not as a 
replacement. If you did not receive this license file, contact HP Support before upgrading. Upgrading before 
applying a new license file can cause your existing licenses to become invalid, resulting in a reduced license 
count (possibly down to zero). 
For more information, see the Rapid Deployment Pack Knowledge Base at 
http://www.hp.com/servers/rdp/kb (Article 136). 

• If you are using Deployment Server Console security, disable it before starting the upgrade, and then re-enable 
it after the upgrade is complete. 

• Shut down all connections to the Deployment Server Console and Deployment Server Web Console. 

Rapid Deployment Pack 2.xx to 3.xx upgrade 
All jobs are new with the 3.xx installation. The job names reflect the Linux or Windows PE preboot environments. The 
jobs no longer use the MS-DOS automation environment. The Linux scripted installation jobs use an FTP connection 
from the Deployment Server and no longer use an NFS server. 

http://www.hp.com/servers/rdp/kb
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Upgrading 
To upgrade the Rapid Deployment Pack software currently installed on the Deployment Server, see the “Installing” 
section in this guide. The Rapid Deployment Pack—Windows Edition 3.xx upgrade process is identical to a first-time 
installation, with the following exceptions: 

• On the Deployment Share Information screen, verify that Upgrade using existing license is selected, and click 
Next. 
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• When prompted to select if you want to use the database from the previous version of the Altiris Deployment 
Server, click Yes to keep all of the data intact. 

 CAUTION:  If you do not retain the existing database, all deployment history, customized jobs, and 
servers listed in the Deployment Server Console are lost. 

 

 
• When prompted to specify the location where PXE is to be installed, either locally or remotely, select Linux or 

Windows PE as the default PXE boot menu item, depending on your primary operating system deployment. 
The default PXE boot menu selection sets the automation environment that a new server initially runs in when 
connecting to the Deployment Server for the first time. All Rapid Deployment Pack jobs work correctly regardless 
of the default PXE boot menu selection. 

 
• When prompted to replace the eXpress share, click Yes. 
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• If jobs or files residing on the Deployment Server already exist or have been modified from a previous 
installation of Rapid Deployment Pack 2.xx or 3.xx, you are prompted to backup or overwrite the existing files. 
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5 Post-installation steps 
Many configuration settings are established during the Rapid Deployment Pack 3.xx software installation. For 
information about changing these configuration settings, see “Appendix B Manually modifying configuration 
settings.” For operating system- and platform-specific configuration requirements, see the predeployment configuration 
information in the HP ProLiant Essentials Rapid Deployment Pack—Windows Edition User Guide. 

This section provides instructions to create physical boot media for server deployment. This process is necessary only 
if PXE is not used in the deployment infrastructure. 

You can use physical boot media, such as a CD-ROM, DVD, or USB device, to connect the target system to the 
Deployment Server. The boot media can be used in the target system drive, or an image of the boot media can be 
accessed using the Remote Insight Lights-Out Edition (RILOE) or Integrated Lights-Out (iLO) Virtual Media option. The 
Virtual Media option is not an integrated feature of the Rapid Deployment Pack. 

 IMPORTANT:  To use the iLO Virtual Media option, you must purchase a license for iLO Advanced Pack. For 
information about iLO Advanced Pack, see http://www.hp.com/servers/lights-out. 
 

Physical boot media must be created after each Rapid Deployment Pack installation or upgrade to verify that the latest 
files and drivers are included. A floppy disk is not a viable form of boot media for the Linux and Windows PE 
automation environments because of disk-space requirements. 

To create a boot disk using the Altiris Boot Disk Creator: 

1. On the Deployment Server Console, select Tools>Boot Disk Creator. 
2. Select Create a new configuration, and click OK. 

 

http://www.hp.com/servers/lights-out
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3. Enter a name for the configuration, such as Windows PE ISO or Linux ISO. Enter a description. 
4. Select Windows PE or Linux in the Pre-boot Operating System for this Configuration field, then select HP in the 

OEM Extensions dropdown list. Click Next. A Windows PE ISO configuration is used as an example in the 
following steps. 

 
 

5. If this is an upgrade and the previous configuration uses the same name, you are prompted to overwrite the 
existing configuration. Click Yes. 
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6. For Windows PE, verify that the Auto-detect all network adapters checkbox is selected, and click Next. 

 
 

 IMPORTANT:  For Linux, click Next. This action uses the drivers provided with the LinuxPE kernel that loads 
based on vendor and PCI dev ice IDs. Selecting All or certain drivers for the target system causes those drivers 
to load regardless of the PCI device ID. This list might include drivers other than network adapter drivers, such 
as storage and management drivers. 
 



 

Post-installation steps 30  
 
 

7. Select the appropriate TCP/IP settings for the target system, and click Next. 

 
 

8. In the Use TCP/IP to connect to the Altiris Deployment Server field, verify that the Server IP address setting 
reflects the Deployment Server IP address, and click Next. 
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9. Enter the appropriate network settings, and click Next. 

 
 

10. Click Next to accept the default drive mapping settings. 
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11. For Windows only, click Next to accept the default boot option. 

 
 

12. Click Finish to create the configuration. 
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13. Select Create an automation boot disk to save the configuration to a disk, and click Next. 

 
 

14. Select one of the following options: 
• For ISO CD images, select Bootable ISO CD Image. 
• For USB disks, select Bootable disk, enter the location of the USB device and follow the specific directions. 

 NOTE:  To display some USB devices, Show fixed drives might need to be selected. 
 

15. Select the appropriate client computer processor type from the dropdown list, for Integrity Servers, select ia64. 

 IMPORTANT:  More than one processor type image might need to be created to run an RDP-provided job. 
For example, Windows x64 scripted install jobs run the hardware configuration tasks using the WinPE 
x86 automation environment and it also runs the Windows install tasks using WinPE x64. 
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16. Click Next. 

 
 

17. Enter the ISO CD image file path, and click Next. 

 
 

18. If the specified directory does not exist, click Yes to create the directory. 
19. If the ISO CD image file already exists, click Yes to replace the file. 
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20. When the disk is complete, click Close. 
 

 NOTE:  To view the contents of the USB device using the Deployment Servers Windows Explorer after Boot Disk 
Creator has saved the files to the device, for some key types you may need to remove the USB device and then 
reinsert it into the USB drive. 

 

 
 

The following steps must be completed on each Integrity target server to use a USB device: 

21. From the target server, insert the USB device into the drive. 
22. From the target’s EFI Boot Manager, select Boot Configuration from the Boot menu. 
23. Select Add Boot Entry. 

 
 

24. Select the entry for the USB drive. 
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25. Enter the description Altiris Automation for this boot entry. 
 

 NOTE:  If any other description is used, move the USB boot entry at the top of the boot order list and 
verify that the LAN boot entries are removed. 

 

26. Press Enter for the Load options field. 
27. Press Y to save changes to NVRAM. 
28. Press Escape to return to the Boot menu. 
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6 HP support and contact information 

Related documents 
HP recommends reviewing the following documentation before reading this guide: 

• HP ProLiant Essentials Rapid Deployment Pack Planning Guide 
• HP ProLiant Essentials Rapid Deployment Pack—Windows Edition Release Notes 
• HP ProLiant Essentials Rapid Deployment Pack—Windows Edition Support Matrix 
HP recommends reviewing the HP ProLiant Essentials Rapid Deployment Pack—Windows Edition User Guide after 
reading this guide. 

All of the documents can be found in PDF format at http://www.hp.com/servers/rdp, from the Rapid Deployment 
Pack DVD autorun utility, at \docs on the product DVD, and at .\docs on the Deployment Server. 

Online resources 
• Information about the Rapid Deployment Pack and the latest updates are available from the HP ProLiant 

Essentials Rapid Deployment Pack website at http://www.hp.com/servers/rdp. 
• Regularly updated troubleshooting information, frequently asked questions, and specific how-to procedures are 

available at the HP ProLiant Essentials Rapid Deployment Pack Knowledge Base at 
http://www.hp.com/servers/rdp/kb. 

• Problem-solving information and ideas from other IT professions are available in the IT Resource Center (ITRC) 
User Forum “ProLiant Deployment & Provisioning.” This forum is accessible from the Management Software and 
System Tools link at http://forums.itrc.hp.com. 

• Information and resources about the Altiris Deployment Solution is available from the Altiris website at 
http://www.altiris.com. 

HP contact information 
For the name of the nearest HP authorized reseller: 

• In the United States, see the HP U.S. service locator webpage at http://www.hp.com/service_locator. 
• In other locations, see the Contact HP worldwide webpage at 

http://welcome.hp.com/country/us/en/wwcontact.html. 
For HP technical support: 

• In the United States, for contact options see the Contact HP United States webpage at 
http://welcome.hp.com/country/us/en/contact_us.html. To contact HP by phone: 
• Call 1-800-HP-INVENT (1-800-474-6836). This service is available 24 hours a day, 7 days a week. For 

continuous quality improvement, calls may be recorded or monitored. 
• If you have purchased a Care Pack (service upgrade), call 1-800-633-3600. For more information about 

Care Packs, see the HP website at http://www.hp.com. 
• In other locations, see the Contact HP worldwide webpage at 

http://welcome.hp.com/country/us/en/wwcontact.html. 

http://www.hp.com/servers/rdp
http://www.hp.com/servers/rdp
http://www.hp.com/servers/rdp/kb
http://forums.itrc.hp.com/
http://www.altiris.com/
http://www.hp.com/service_locator
http://welcome.hp.com/country/us/en/wwcontact.html
http://welcome.hp.com/country/us/en/contact_us.html
http://www.hp.com/
http://welcome.hp.com/country/us/en/wwcontact.html
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Appendix A Manually installing operating system CDs or 
DVDs 

If you did not copy the Windows, VMware, or Red Hat Linux operating system CDs or DVDs during the installation, 
manually copy the files for each omitted operating system to verify that the provided Windows, VMware, and Red 
Hat Linux jobs operate properly. Manually copying the Windows, VMware, and Red Hat Linux operating system files 
using the following steps produces the same results as copying the files when prompted during the Rapid Deployment 
Pack installation. 

The provided scripted installation jobs rely on the existence of operating system files at .\lib\osdist\yyyy, where yyyy 
indicates the operating system shortcut name. 

To manually copy the operating system files to the Deployment Server directory: 

1. Locate the appropriate .\lib\osdist directory on the Deployment Server. 
2. Select the appropriate directory for the operating system files to be copied. 
 

Table 1  Operating system directory names 

Operating system  Directory name 

Windows 2000 Server w50s 

Windows 2000 Advanced Server w50as 

Windows Server 2003, Standard Edition w52s 

Windows Server 2003, Enterprise Edition w52e 

Windows Server 2003, Web Edition w52w 

Windows Server 2003, Standard x64 Edition w52s.64 

Windows Server 2003, Enterprise x64 Edition w52e.64 

Windows Server 2003 IA64, Enterprise Edition w52e.ia64 

Red Hat Enterprise Linux AS 3 Update 8 for x86 rhas3u8 

Red Hat Enterprise Linux ES 3 Update 8 for x86 rhes3u8 

Red Hat Enterprise Linux AS 3 Update 8 for AMD64 and Intel EM64T  rhas3u8.64 

Red Hat Enterprise Linux ES 3 Update 8 for AMD64 and Intel EM64T  rhes3u8.64 

Red Hat Enterprise Linux AS 4 Update 4 for x86 rhas4u4 

Red Hat Enterprise Linux ES 4 Update 4 for x86 rhes4u4 

Red Hat Enterprise Linux AS 4 Update 4 for AMD64 and Intel EM64T rhas4u4.64 

Red Hat Enterprise Linux ES 4 Update 4 for AMD64 and Intel EM64T rhes4u4.64 

Red Hat Enterprise Linux AS 4 Update 4 for Intel Integrity rhas4u4.ia64 

Red Hat Enterprise Linux ES 4 Update 4 for Intel Integrity rhes4u4.ia64 

VMware ESX Server 2.5.3 vmesx253 

VMware ESX Server 3.0.1 vmesx301 

SUSE Linux Enterprise Server 10 for x86 sles10 

SUSE Linux Enterprise Server 10 for AMD64 and Intel EM64T sles10.64 
 

3. Copy the entire contents of each operating system CD or DVD to the operating system directory. 
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Appendix B Manually modifying configuration settings 

Synchronizing the Deployment Server Console names with the target 
server computer names 

The Deployment Server can use a console display name that is different from the actual computer name. However, 
you can select to have the console always reflect the same name as the computer name. This option can be enabled 
during the Rapid Deployment Pack installation by selecting the Enable Synchronize display names with computer 
names checkbox on the Configuration Options window. 

To enable synchronization of the Deployment Server Console and operating system names after the Rapid 
Deployment Pack installation: 

1. Select Tools> Options from the Deployment Server Console. 
2. Click the Global tab from the Program Options screen. 

 
3. Select the Synchronize display names with computer names checkbox, and click OK. 
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Modifying the primary lookup key 
The Deployment Server uses the primary lookup key to determine if a server is already in the database. HP 
recommends setting the primary lookup key as the server serial number. Setting the primary lookup key as the server 
serial number has two benefits: 

• It enables servers to be imported by their serial number, rather than keys that are more difficult to determine, 
such as the MAC address. 

• It prevents duplicate database entries from occurring when servers have two or more NICs. 
The primary lookup key can be set as the server serial number during the Rapid Deployment Pack installation by 
setting the Primary lookup key dropdown list to Serial Number. 

To set the primary lookup key as the server serial number after the Rapid Deployment Pack installation: 

1. Select Tools>Program Options from the Deployment Server Console.  
2. Click the Global tab from the Program Options window. 

 
3. From the Primary lookup key dropdown list, select Serial Number. 
4. Click OK. 
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Configuring PXE to automatically process new computers 
By default, when a new computer (a computer not listed in the Deployment Server database) performs a PXE boot, the 
PXE server sends the computer the PXE menu and waits for manual selection of the Initial Deployment option. This 
process is not practical for servers, especially server blades with no local keyboard, mouse, or display. 

You can set the Initial Deploy boot option to use the default timeout by selecting this option on the Configuration 
Options screen. 

To change the Initial Deployment option after the Rapid Deployment Pack Installation: 

1. Select Tools>PXE Configuration from the Deployment Server Console menu. 
2. Click the DS tab. 

 
3. Select Use default timeout. 
4. Click Save. 
5. Click OK. 
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Client/server file transfer port set to 4300 
For adlagent to properly transfer files under VMware ESX 3.x, the client/server file transfer port must be set to match 
the value in the supplied ESX kickstart files. 

To set the client/server file transfer port to 4300 after the Rapid Deployment Pack installation: 

1. Select Tools>Program Options from the Deployment Server Console. 
2. Click the Global tab from the Program Options window. 

 
3. Select the Client/server file transfer port checkbox, and enter 4300. 
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Creating an IIS FTP virtual directory 
For Linux and VMware ESX Server scripted installation deployments, a virtual directory must be configured on an FTP 
server, such as IIS. If IIS is installed, you can configure the virtual directory by selecting the Create IIS FTP virtual 
directory “DSLIB” checkbox on the Configuration Options screen. 

If you use an FTP server other than IIS, use the same entry settings. 

To configure IIS FTP after the Rapid Deployment Pack installation: 

1. Launch the Internet Information Services (IIS) Manager. 
2. Expand the directory in the left pane, and select Default FTP Site or another existing FTP site. 
3. Right-click the FTP site, and select New>Virtual Directory. 
4. Complete the Virtual Directory wizard, entering the following information when prompted. 
 

Table 2  Virtual directory information 

Field Entry 

Virtual Directory Alias DSLIB 

FTP Site Content Directory 1C:\Program Files\Altiris\eXpress\Deployment Server\lib 

Virtual Directory Access Permissions Read 

1This value assumed that the Deployment Server was installed on the C drive. 
 

5. Right-click the FTP site and select Properties. 
6. Click the Security Accounts tab. 
7. Select Allow Anonymous Connections, and click OK. 
8. If the FTP site name is followed by “(Stopped),” right-click the site name, and select Start. 

Windows product keys 
For Windows scripted installation deployments, a Windows product key must be provided. You can enter these keys 
in the Windows 2000 Product Key, Windows 2003 Product Key, Windows 2003 x64 Product Key, or Windows 
2003 ia64 Product Key fields on the Configuration Options screen during the initial Rapid Deployment Pack 
installation. 

To manually configure or reconfigure the Windows product keys after the initial Rapid Deployment Pack installation, 
use the User Tokens Editor accessed from the Deployment Server Console at Tools>Integration Module. 
 

Table 3  User Tokens table entries 

Name Value 

w50productkey XXXXX-XXXXX-XXXXX-XXXXX-XXXXX 

w52productkey XXXXX-XXXXX-XXXXX-XXXXX-XXXXX 

w52.64productkey XXXXX-XXXXX-XXXXX-XXXXX-XXXXX 

w52.ia64productkey XXXXX-XXXXX-XXXXX-XXXXX-XXXXX 
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Appendix C Installing an FTP server 
For Linux and VMware ESX Server deployments, an FTP server must be installed, such as the Microsoft IIS FTP service. 

To install ISS FTP service: 

1. Log in to the Deployment Server as a user with administrator rights. 
2. Click Start>Control Panel>Add/Remove Programs. 
3. Click Add/Remove Windows Components. 
4. For Windows Server 2003 systems, select Application Server, and click Details. 
5. Select Internet Information Services (IIS), and click Details. 
6. Select File Transfer Protocol (FTP) Server and click OK. 
7. For Windows Server 2003 systems, click OK again. 
8. Click Next. 
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